Have you ever tried to copy some cells in Excel and gotten the Cannot empty the clipboard error message? I was recently the victim of this annoying error, which would pop up EVERY time I tried to copy data from any cell on my spreadsheet.

The strange thing is that the copy still works for me, but I have to keep clicking OK to remove the error message. After some reading and playing around on my own, I’ve learned that this error can happen for all kinds of reasons and there are a number of fixes you can try to troubleshoot the error.

Table of Contents

    cannot empty the clipboard

    For the most part, you’ll see this error in Microsoft Excel and Word, especially when you are trying to copy any kind of data. Here are all the possible solutions I could find. If you have a different solution, feel free to post it in the comments.

    Method 1:

    Sometimes in Excel you can get this error if a cell has been copied and you try to copy another cell. You can try to press the ESC key to deselect the copied cell and then try to copy again.

    This method might let you copy one time, but you may still get the error message on the next attempt to copy. It’s not a permanent fix.

    Method 2:

    Another thing you can try is to open the clipboard in Windows and leave it open. Sometimes doing this can help get rid of the error. It’s not a great solution, but these are the strange things you have to do in Windows!

    You can open the Clipboard by going to Start, Run and typing in clipbrd.exe. You can also go to Windows\System32 directory and double-click on clipbrd.exe.

    clipbook viewer

    Method 3:

    If you’ve been using Remote Desktop, you may get the Cannot Copy to Clipboard error because Remote Desktop uses the clipboard and it can cause weird issues with Excel.

    Go to Task Manager, click on the Processes tab, kill the process called rdpclip.exe and see if that fixes your problem! If you have UltraVNC installed, it may also be the culprit!

    Any kind of remote desktop software could be causing the issue, so make sure to check to see if you have the problem when one of those programs are running.

    Method 4:

    Go to Excel, click on Tools, then Options, and go to the Calculation tab. Make sure that Automatic is selected from the three options. In newer versions of Excel, you click on File, then Options and then click on Formulas in the left-hand tab.

    excel automatic calculation

    In newer versions of Excel, you have to click on File, Options and then click on Formulas.

    excel automatic calculation

    Method 5:

    If you have a program like GetRight or Flashget installed on your computer, you will have to go in and uncheck the option for “Monitor the clipboard”.

    Any other program that may try to use the Windows Clipboard could be causing the problem, so uninstall any third party software that you know uses the clipboard.

    Method 6:

    Clear the office clipboard by going to Edit and choosing Office Clipboard. This will only work for Office XP and 2003. Now go ahead and click Clear All to clear the office clipboard completely.

    clear all office clipboard

    Also, at the bottom of the screen, you should see an Options button. Click on that and select the “Collect without showing office clipboard” option.

    Method 7:

    Microsoft has written about this error in their KB and they have a hotfix for it, but it may or may not work for you. It’s only for Windows Server 2003 and it has to do with Terminal Services.

    You can download the hotfix here: http://support.microsoft.com/?id=840872.

    That’s all the solutions I could find for not being able to empty the clipboard! If you have another solution that has worked for you, post a comment here! Good luck!

    Windows has lots of cryptic messages like this and I’ve written about a few of them before like how to fix missing or corrupt NTFS.sysfix Windows Search Indexer has stopped workingfix USB device not recognized in Windows, and fix for host process in Windows has stopped working error. Whew!